Camera firmware notice

Due to the configuration of DJI components used, you may be presented with a ‘camera firmware update required’ message via the DJI GO app.

Please note this is a false message and can be ignored.

Your machine is shipped with the latest compatible firmware for the drone – which is the DJI OSMO firmware version 1.8.2.40 This will not need updating.

Please do not attempt to update the camera with any other firmware version as this may result in the camera not functioning.